Why do I need to provide documentation for verification of a SSL certificate?

Solution ID:    SO16926    Updated:    03/13/2014

Problem

Why do I need to provide a Professional Opinion Letter for SSL, or a recent bill with a phone number signed by Lawyer/Accountant/Government Official/Justice of the Peace/Notary Public for the final verification phone call?

Cause

Thawte is unable to obtain a telephone number for the organization name listed in your order.  The telephone number must be listed in a public, third party telephone directory, such as directory assistance.

Thawte must contact your organization through this telephone number and confirm your knowledge of the order.

Solution

If the organization in your order has a telephone number listed with a third party directory, such as directory assistance, please contact Customer Support using the contact information below.

If the organization in your order does not have a publicly-listed telephone number, please fax or e-mail a Professional Opinion Letter for SSL or recent bill with a phone number signed by Lawyer/Accountant/Government Official/Justice of the Peace/Notary Public for the final verification phone call to the contact information below.

If you have any questions, please contact Customer Support.

--------------------------------------------------------------------------------------------------------------------------------
Contact Thawte

Americas:
Telephone: 520-477-3114 option 1, or 866-239-4520 option 1
Fax: 1-650-237-8888
E-mail: cs-support@thawte.com
Chat: http://www.thawte.com/chat/chat_cs_us.html


Australia and Asia Pacific:
Telephone: +61 03 9914 5641
Fax: +61 2 8023 8315
E-mail: apacsupport@thawte.com
Chat: http://www.thawte.com/chat/chat_cs_international.html

 

Europe, Middle East, and Africa:
Telephone: +353 1 793 9029
Fax: +353 1 850 2240
E-mail: emeasupport@thawte.com
Chat: http://www.thawte.com/chat/chat_cs_international.html

 

Contact Details:
http://www.thawte.com/about/contact/index.html

Find Answers


Search Tips